Discussion:
Issue 539698 in chromium: Can't run autotest directly on DUT anymore
(too old to reply)
c***@googlecode.com
2015-10-06 01:50:43 UTC
Permalink
Raw Message
Status: Untriaged
Owner: ----
Labels: Type-Bug Pri-2 Cr-Test OS-Chrome M-48

New issue 539698 by ***@chromium.org: Can't run autotest directly on DUT
anymore
https://code.google.com/p/chromium/issues/detail?id=539698

The runlevel error looks like a wrong lead, as even on older builds where
one can execute tests directly it shows this error. So the failure probably
happens before?

Failure is from 7521.0.0 (Official Build) dev-channel lumpy test
On link 7503 it still works.

localhost autotest # bin/autotest tests/security_NetworkListeners/control
DEBUG:root:Failed to import elasticsearch. Mock classes will be used and
calls to Elasticsearch server will be no-op. Test run is not affected by
the missing elasticsearch module.
17:56:46 INFO | Writing results to /usr/local/autotest/results/default
17:56:46 CRITI| JOB ERROR (autotest bug?): Command </sbin/runlevel> failed,
rc=1, Command returned non-zero exit status
* Command:
/sbin/runlevel
Exit status: 1
Duration: 0.00397109985352

stderr:
runlevel:/var/run/utmp: No such file or directory
Traceback (most recent call last):
File "/usr/local/autotest/bin/job.py", line 1297, in runjob
myjob = job(control=control, drop_caches=drop_caches, options=options)
File "/usr/local/autotest/bin/site_job.py", line 19, in __init__
base_client_job.__init__(self, *args, **kwargs)
File "/usr/local/autotest/bin/job.py", line 113, in __init__
self._pre_record_init(control, options)
File "/usr/local/autotest/bin/job.py", line 196, in _pre_record_init
self.harness = harness.select(_harness, self, _harness_args)
File "/usr/local/autotest/bin/harness.py", line 95, in select
harness_instance = getattr(harness_module, harness_name)(job,
harness_args)
File "/usr/local/autotest/bin/harness_standalone.py", line 41, in __init__
initdefault = utils.system_output('/sbin/runlevel').split()[1]
File "/usr/local/autotest/common_lib/base_utils.py", line 1196, in
system_output
args=args).stdout
File "/usr/local/autotest/common_lib/base_utils.py", line 893, in run
"Command returned non-zero exit status")
CmdError: Command </sbin/runlevel> failed, rc=1, Command returned non-zero
exit status
* Command:
/sbin/runlevel
Exit status: 1
Duration: 0.00397109985352

stderr:
runlevel:/var/run/utmp: No such file or directory
--
You received this message because this project is configured to send all
issue notifications to this address.
You may adjust your notification preferences at:
https://code.google.com/hosting/settings
--
--
Automated mail from issue updates at http://crbug.com/
Subscription options: http://groups.google.com/a/chromium.org/group/chromium-bugs

To unsubscribe from this group and stop receiving emails from it, send an email to chromium-bugs+***@chromium.org.
c***@googlecode.com
2015-11-18 15:26:24 UTC
Permalink
Raw Message
Comment #9 on issue 539698 by ***@chromium.org: Can't run autotest
directly on DUT anymore
https://code.google.com/p/chromium/issues/detail?id=539698

Re #8: Why would re-imaging from a USB make any difference? I'm
using 'cros flash' to copy images to ip, to install the test image on the
dut -- is that not sufficient?

Can somebody fix this? It's critical for my policy AutoTest testing.
--
You received this message because this project is configured to send all
issue notifications to this address.
You may adjust your notification preferences at:
https://code.google.com/hosting/settings
--
--
Automated mail from issue updates at http://crbug.com/
Subscription options: http://groups.google.com/a/chromium.org/group/chromium-bugs

---
You received this message because you are subscribed to the Google Groups "Chromium-bugs" group.
To unsubscribe from this group and stop receiving emails from it, send an email to chromium-bugs+***@chromium.org.
c***@googlecode.com
2017-01-31 08:33:32 UTC
Permalink
Raw Message
Comment #13 on issue 539698 by ***@google.com: Can't run autotest
directly on DUT anymore
https://code.google.com/p/chromium/issues/detail?id=539698

Issue chrome-os-partner:62442 has been merged into this issue.
--
You received this message because this project is configured to send all
issue notifications to this address.
You may adjust your notification preferences at:
https://code.google.com/hosting/settings
--
--
Automated mail from issue updates at http://crbug.com/
Subscription options: http://groups.google.com/a/chromium.org/group/chromium-bugs

---
You received this message because you are subscribed to the Google Groups "Chromium-bugs" group.
To unsubscribe from this group and stop receiving emails from it, send an email to chromium-bugs+***@chromium.org.
Loading...