Discussion:
Issue 2648 in chromium: clicking on link gives Error 320 (net::ERR_INVALID_RESPONSE): Unknown error
(too old to reply)
c***@google.com
2008-10-06 14:47:27 UTC
Permalink
Issue 2648: clicking on link gives Error 320 (net::ERR_INVALID_RESPONSE):
Unknown error
http://code.google.com/p/chromium/issues/detail?id=2648

Comment #1 by gray.theo:
This appears to occur on sites where the server returns a "303 See Other"
response
rather than (I guess) the 301 or 302 that Chrome is expecting.
--
You received this message because you are listed in the owner
or CC fields of this issue, or because you starred this issue.
You may adjust your issue notification preferences at:
http://code.google.com/hosting/settings

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "Chromium-bugs" group.
To post to this group, send email to chromium-***@googlegroups.com
To unsubscribe from this group, send email to chromium-bugs+***@googlegroups.com
For more options, visit this group at http://groups.google.com/group/chromium-bugs?hl=en
-~----------~----~----~----~------~----~------~--~---
c***@google.com
2008-10-06 15:01:30 UTC
Permalink
Issue 2648: clicking on link gives Error 320 (net::ERR_INVALID_RESPONSE):
Unknown error
http://code.google.com/p/chromium/issues/detail?id=2648

Comment #2 by gray.theo:
Further example:



Returns:

HTTP/1.1 303 See Other
Date: Mon, 06 Oct 2008 14:35:38 GMT
Server: Apache
Set-Cookie: use_hitbox=1111111111111111111111111111111111111111; path=/;
domain=.youtube.com
Set-Cookie: PREF=f1=1000000&gl=GB&hl=en-GB; path=/; domain=.youtube.com;
expires=Thu, 04-Oct-2018 14:35:38 GMT
Set-Cookie: GEO=1111111111111111111111111111111111111111111111111111111=;
path=/;
domain=.youtube.com; expires=Wed, 08-Oct-2008 14:35:38 GMT
Expires: Tue, 27 Apr 1971 19:44:06 EST
Cache-Control: no-cache
Location: http://youtu.be/1aBaX9GPSaQ
Keep-Alive: timeout=300
Connection: Keep-Alive
Transfer-Encoding: chunked
Content-Type: text/html; charset=utf-8


Chrome errors with 320 ERR_INVALID_RESPONSE
--
You received this message because you are listed in the owner
or CC fields of this issue, or because you starred this issue.
You may adjust your issue notification preferences at:
http://code.google.com/hosting/settings

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "Chromium-bugs" group.
To post to this group, send email to chromium-***@googlegroups.com
To unsubscribe from this group, send email to chromium-bugs+***@googlegroups.com
For more options, visit this group at http://groups.google.com/group/chromium-bugs?hl=en
-~----------~----~----~----~------~----~------~--~---
c***@google.com
2008-10-06 15:09:32 UTC
Permalink
Issue 2648: clicking on link gives Error 320 (net::ERR_INVALID_RESPONSE):
Unknown error
http://code.google.com/p/chromium/issues/detail?id=2648

Comment #3 by gray.theo:
The vrbo.com response comes back with the header:

HTTP/1.1 200 OK
Connection: close
Date: Mon, 06 Oct 2008 14:59:47 GMT
Server: Microsoft-IIS/6.0
p3p: policyref="http://www.homeawayconnect.com/w3c/p3p.xml", CP="CUR ADM
DEV CUS
OUR IND DSP ALL COR"
X-Powered-By: ASP.NET
Pragma: no-cache
Expires: <cfoutput>Monday,Oct
06 08
09:59:47
AM</cfoutput>
Content-Language: en-US
Content-Type: text/html; charset=UTF-8
cache-control: no-cache, no-store, must-revalidate
Set-Cookie: NSC_IBD-sfoupst_IUUQ=111111111111;expires=Mon, 06-Oct-08
16:26:04 GM
T;path=/

So possibly the Expires in that case is causing Chrome to get upset?
--
You received this message because you are listed in the owner
or CC fields of this issue, or because you starred this issue.
You may adjust your issue notification preferences at:
http://code.google.com/hosting/settings

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "Chromium-bugs" group.
To post to this group, send email to chromium-***@googlegroups.com
To unsubscribe from this group, send email to chromium-bugs+***@googlegroups.com
For more options, visit this group at http://groups.google.com/group/chromium-bugs?hl=en
-~----------~----~----~----~------~----~------~--~---
v.razinkov
2008-10-08 12:16:57 UTC
Permalink
In my appinion it's a conflict with antivirus. Try disabling your
antivirus software and see if the problem disappears. It seems that
some network traffic filtering antiviruses are not compatible with
Chrome. For example in my tests Kaspersky Internet Security (KIS) 7.0
causes the problem, but KIS 2008 works fine with Chrome. Avira Antivir
2008 work fine too.
Issue 2648: clicking on link gives Error 320 (net::ERR_INVALID_RESPONSE):  
Unknown errorhttp://code.google.com/p/chromium/issues/detail?id=2648
This appears to occur on sites where the server returns a "303 See Other"  
response
rather than (I guess) the 301 or 302 that Chrome is expecting.
--
You received this message because you are listed in the owner
or CC fields of this issue, or because you starred this issue.
You may adjust your issue notification preferences at:http://code.google.com/hosting/settings
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "Chromium-bugs" group.
To post to this group, send email to chromium-***@googlegroups.com
To unsubscribe from this group, send email to chromium-bugs+***@googlegroups.com
For more options, visit this group at http://groups.google.com/group/chromium-bugs?hl=en
-~----------~----~----~----~------~----~------~--~---
c***@google.com
2008-10-08 18:11:31 UTC
Permalink
Issue 2648: clicking on link gives Error 320 (net::ERR_INVALID_RESPONSE):
Unknown error
http://code.google.com/p/chromium/issues/detail?id=2648

Comment #4 by ***@chromium.org:
Works fine when running Chrome with the --new-http command line flag.
--
You received this message because you are listed in the owner
or CC fields of this issue, or because you starred this issue.
You may adjust your issue notification preferences at:
http://code.google.com/hosting/settings

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "Chromium-bugs" group.
To post to this group, send email to chromium-***@googlegroups.com
To unsubscribe from this group, send email to chromium-bugs+***@googlegroups.com
For more options, visit this group at http://groups.google.com/group/chromium-bugs?hl=en
-~----------~----~----~----~------~----~------~--~---
Loading...